Add watch file
[joel/debian/python-pysqlite2.git] / debian / changelog
1 python-pysqlite2 (2.6.3-1) unstable; urgency=low
2
3   * New upstream version.
4   * Updated Standards-Version to 3.9.1.
5   * Added watch file.
6
7  -- Joel Rosdahl <joel@debian.org>  Sun, 20 Feb 2011 17:00:22 +0100
8
9 python-pysqlite2 (2.6.0-1) unstable; urgency=low
10
11   * New upstream version.
12   * Changed source package format to "3.0 (quilt)".
13   * Updated Standards-Version to 3.8.4.
14   * Don't compile with debug information in the non-dbg package.
15   * Added missing ${misc:Depends}.
16
17  -- Joel Rosdahl <joel@debian.org>  Sun, 16 May 2010 15:53:25 +0200
18
19 python-pysqlite2 (2.5.5-3) unstable; urgency=low
20
21   * Bumped build dependency on python-all-dev to >= 2.5.4. Closes: #551692.
22
23  -- Joel Rosdahl <joel@debian.org>  Tue, 20 Oct 2009 22:05:32 +0200
24
25 python-pysqlite2 (2.5.5-2) unstable; urgency=low
26
27   * Allow building with Python 2.6. Patch by Andrew Starr-Bochicchio and
28     Stefano Zacchiroli; thanks! Closes: #532014,#547850.
29   * Don't build with SQLITE_OMIT_LOAD_EXTENSION. Closes: #543252.
30   * Updated to Standards-Version 3.8.3.
31
32  -- Joel Rosdahl <joel@debian.org>  Tue, 13 Oct 2009 22:59:44 +0200
33
34 python-pysqlite2 (2.5.5-1) unstable; urgency=low
35
36   * New upstream release.
37   * Updated to Standards-Version 3.8.1.
38   * pysqlite now by default enforces UTF-8 strings. Closes: #469644.
39   * Fixed build problem using new Sphinx versions. Closes: #527494.
40
41  -- Joel Rosdahl <joel@debian.org>  Sun, 10 May 2009 22:15:42 +0200
42
43 python-pysqlite2 (2.5.0-2) unstable; urgency=low
44
45   * Moved documentation to a separate package:
46     python-pysqlite2-doc. Closes: #500425.
47
48  -- Joel Rosdahl <joel@debian.org>  Sun, 28 Sep 2008 10:14:22 +0200
49
50 python-pysqlite2 (2.5.0-1) unstable; urgency=low
51
52   * New upstream release.
53   * Updated to Standards-Version 3.8.0.
54
55  -- Joel Rosdahl <joel@debian.org>  Sat, 27 Sep 2008 11:04:12 +0200
56
57 python-pysqlite2 (2.4.1-1) unstable; urgency=low
58
59   * New upstream release.
60   * Updated to Standards-Version 3.7.3.
61   * Capitalized Python correctly in descriptions.
62
63  -- Joel Rosdahl <joel@debian.org>  Sun, 10 Feb 2008 12:25:38 +0100
64
65 python-pysqlite2 (2.4.0-2) unstable; urgency=low
66
67   * Made Unicode string work as database parameter again. Closes: #454424.
68
69  -- Joel Rosdahl <joel@debian.org>  Wed, 05 Dec 2007 23:14:41 +0100
70
71 python-pysqlite2 (2.4.0-1) unstable; urgency=low
72
73   * New upstream release.
74   * Added doc-base registration file again. It was lost in
75     2.3.2-2. Closes: #451676.
76
77  -- Joel Rosdahl <joel@debian.org>  Mon, 03 Dec 2007 19:36:47 +0100
78
79 python-pysqlite2 (2.3.4-2) unstable; urgency=low
80
81   * Build python-pysqlite2-dbg package based on Ubuntu patch.
82
83  -- Joel Rosdahl <joel@debian.org>  Thu, 21 Jun 2007 22:54:43 +0200
84
85 python-pysqlite2 (2.3.4-1) unstable; urgency=low
86
87   * New upstream release.
88
89  -- Joel Rosdahl <joel@debian.org>  Wed, 20 Jun 2007 21:15:20 +0200
90
91 python-pysqlite2 (2.3.3-2) unstable; urgency=low
92
93   * Removed DH_COMPAT variable from debian/rules to fix Lintian warning.
94
95  -- Joel Rosdahl <joel@debian.org>  Sun, 22 Apr 2007 22:05:55 +0200
96
97 python-pysqlite2 (2.3.3-1) unstable; urgency=low
98
99   * New upstream release.
100
101  -- Joel Rosdahl <joel@debian.org>  Mon, 26 Feb 2007 20:52:05 +0100
102
103 python-pysqlite2 (2.3.2-2) unstable; urgency=low
104
105   * Applied patch on http://www.initd.org/tracker/pysqlite/ticket/174 to
106     avoid symbol clash between mod_python and mod_cache under
107     Apache. Closes: #407165.
108   * Updated dependencies for debhelper and python-central.
109   * Removed use of dh_python.
110
111  -- Joel Rosdahl <joel@debian.org>  Mon, 29 Jan 2007 22:16:14 +0100
112
113 python-pysqlite2 (2.3.2-1) unstable; urgency=low
114
115   * New upstream release.
116
117  -- Joel Rosdahl <joel@debian.org>  Tue,  4 Jul 2006 09:08:53 +0000
118
119 python-pysqlite2 (2.3.1-1) unstable; urgency=low
120
121   * New upstream release.
122   * Removed XS-Python-Standards-Version header and added debian/pycompat
123     file.
124   * Bumped Build-Depends on debhelper to (>= 5.0.37.2).
125
126  -- Joel Rosdahl <joel@debian.org>  Wed, 21 Jun 2006 06:34:04 +0000
127
128 python-pysqlite2 (2.3.0-1) unstable; urgency=low
129
130   * New upstream release.
131   * Adapt to new Python policy. Closes: bug#373346.
132   * Updated Standards-Version to 3.7.2.
133
134  -- Joel Rosdahl <joel@debian.org>  Mon, 19 Jun 2006 18:30:03 +0000
135
136 python-pysqlite2 (2.2.2-1) unstable; urgency=low
137
138   * New upstream release. Closes: bug#362830.
139   * Updated upstream source URL in copyright.
140
141  -- Joel Rosdahl <joel@debian.org>  Fri, 21 Apr 2006 11:35:31 +0200
142
143 python-pysqlite2 (2.2.0-1) unstable; urgency=low
144
145   * New upstream release. Closes: bug#361066, bug#361068.
146     See also bug#361097.
147   * Added build dependency on libsqlite3-dev >= 3.0.8.
148
149  -- Joel Rosdahl <joel@debian.org>  Thu,  6 Apr 2006 22:32:46 +0200
150
151 python-pysqlite2 (2.0.5-1) unstable; urgency=low
152
153   * New upstream release.
154
155  -- Joel Rosdahl <joel@debian.org>  Sun, 23 Oct 2005 19:14:57 +0200
156
157 python-pysqlite2 (2.0.4-2) unstable; urgency=low
158
159   * Improved description field of the binary package python-pysqlite2.
160
161  -- Joel Rosdahl <joel@debian.org>  Fri, 14 Oct 2005 10:03:02 +0200
162
163 python-pysqlite2 (2.0.4-1) unstable; urgency=low
164
165   * New upstream release.
166
167  -- Joel Rosdahl <joel@debian.org>  Mon, 12 Sep 2005 08:35:17 +0200
168
169 python-pysqlite2 (2.0.3-3) unstable; urgency=low
170
171   * Additional clarification regarding Python SQLite modules added to
172     description.
173   * Added README.Debian with information about different Python SQLite
174     modules.
175   * Improved doc-base information.
176   * Updated copyright file with new URL.
177
178  -- Joel Rosdahl <joel@debian.org>  Fri,  9 Sep 2005 19:14:01 +0200
179
180 python-pysqlite2 (2.0.3-2) unstable; urgency=low
181
182   * Added doc-base information.
183   * Standards-Version 3.6.2.
184   * Clarified package description regarding SQLite 3 versus SQLite 2 and
185     the python-sqlite package.
186
187  -- Joel Rosdahl <joel@debian.org>  Fri,  2 Sep 2005 17:52:26 +0200
188
189 python-pysqlite2 (2.0.3-1) unstable; urgency=low
190
191   * New upstream release.
192
193  -- Joel Rosdahl <joel@debian.org>  Sun, 29 May 2005 10:18:49 +0200
194
195 python-pysqlite2 (2.0.2-1) unstable; urgency=low
196
197   * First packaged version. Closes: bug#309371.
198
199  -- Joel Rosdahl <joel@debian.org>  Sat, 21 May 2005 10:22:19 +0200